Credit Suisse Application Submission

Credit Suisse
#1

Is anyone else having a problem submitting your application online via CS. They;ve changed their application process and its a different system. I have tried all day today with no luck what so ever. I keep getting an error page. Anyone else getting this or is it just me?

T

#2

tommy_86 - I have the same problem… i can only search for the vacancy, and cant even apply! the whole system is very slow and after a few minutes, it gives me an error and cant do anything… been trying all week… same thing happens all the time!

#3

Thanks IBD_Haunter - It’s infuriated me. I spent all of last night and this morning. Tried to get in touch with Grad Recruitment, the guy said you need to email the accessibility email which I have done and still no response. EVen sent them a screen shot of their rubbish system. The system they used last year was perfect - why do they feel they need to change it? :@ To a system that doesn’t work!!! :@

What about you? Have you emailed them? Heard anything?

#4

it is working for me

#5

That’s shocking… have you submitted your application? The site is running extremely slow with continous error pages.

#6

Thats right, when I try to sign in some error pages are coming up, but after couple of times it worked. However, the site is running very slowly indeed.

#7

Oh okay, but I keep getting a message that says “An error has occurred. Please connect using one of the following links:”

It works for a little bit, I can see the current jobs they have, but as soon as I click advanced search and choose a region to apply to, tihis is what comes up. Did yours submit through successfully?

#8

yes, I did…it was just a CV really

#9

still not working for me

#10

yeh same its being a pain! was working in da afternoon!!

#11

Have you been able to send yours through CK?

#12

i gave up! I will send it once they fix this slow system!

#13

It still ain’t working. How are we supposed to get an application in without it working. They really suck!!!

#14

I get access… but when uploading CV… I get CV upload failed!

#15

LOl, I had that issue all day on Tuesday, then since yesterday, all I am getting is “An error occurred while trying to connect.”

#16

hey tommy,

i have just left that form just not gettin any where with it, like the others will get to it wen it works!

will post on it if it starts to work for me.

ck

#17

It still doesn’t work for me, I can only see half of the screen and when I click on Français or Deutsch nothing happens :-s… Anyone been sucussfull sofar??

#18

Has anyone submitted it. I uploaded my CV and it’s extracted the incorrect information! So where my degree was Computing, it extracted Security instead!!! And it’s not possible to modify.

IBD_Haunter and meritocrat - it’s just a CV to submit right? That’s all it asks for! Did you get anything different?

Has anyone heard anything from here too?

#19

you have to submit both CV and cover letter…

#20

Have you heard back from them yet?